Does A BLE Module Need Support MFi Protocol And Apply MFi Certification?

- Apr 14, 2020-

''Will the MFI compliant products on your website work seamlessly with iPhone and iPads without need for any additional authentication chips to be interfaced with the BLE modules?''


BLE module does not need support MFi.


MFi is an identification license for Apple Inc.'s external accessories manufactured by its authorized accessory manufacturers.


Only if use apple phone by SPP protocol, then you need pass MFi Certification. And MFi certification is a little complex. Below some details about MFi.


But your requirement only need BLE, so the module does not need support MFi protocol and you do not need pass MFi certification.


For ble module, we recommend FSC-BT630, FSC-BT616, FSC-BT646.


FSC-BT616: Bluetooth 5.0, Bluetooth low energy. TI CC2640 Chipset.


FSC-BT630: Bluetooth 5.0, Bluetooth low energy. Nordic 52832 Chipset.


FSC-BT646: Bluetooth 4.2, low cost module with PAN1020 Chip.